Page 1 of 2

MOA 2.4.1 setup

PostPosted: Tue Sep 28, 2010 8:13 pm
by ullihankeln
NEW - the setup now should work on Windows 7 - 32 bit and 64 bit

thanks a lot to JFX

Version: now builds 2.4.109

download : moa241-setup-v3.exe

WARNING: some Antivirus-scanner do not like executables created with Autoit.
When your setup fails try to disable your Virus-scanner.


Video guide through the setup

System requirement:
The initial setup MUST be done with a XP-32bit or 2k3-32bit machine - running the setup in a virtual machine is recommended.

I can't help with any issues on Vista, 2008, Windows 7 or 64bit systems.
Once the initial setup is done and you have one working MOA you should then use MOA to run the setup or do any further customisations

whats new ?
MOA 2.4.1 supports Workstation 6.5.4 and older, ViClient and vSphere-client.
MOA 2.4.1 setup now uses the wizard only once.
When the directory ...\pebuilder exists you can not run it again.
Only postprocessing options are available.

Start from scratch - create a new directory without spaces in the name on a NTFS formatted drive. Download setup and run it.


or better - using reference sources: X13-05665.img


To start from scratch without being online create a new directory and put the setup and all moa*.zip files from last run into it.

If you follow the wizard with all defaults and do not use any customizations or postprocessing you get a decent ColdClone CD.

Thats the new wizard "create MOA-core"







The new "create MOA-core" wizard only asks the listed questions.
After the wizard has done its work you should find a moa24-std.iso in iso-out.

To do postprocessing you must close the setup now and relaunch it.

Config options in MOA 2.4.1 setup


you only need this in one case : to prepare a offline build - use this to grab the files when you are online somewhere - just for convenience ...
In a regular build you do NOT need to use any of these options.

New postprocessing options in MOA 2.4.1 setup


Warning - read me:

at the moment the referenced mirror for the Pebuilder seems to be down.
Download pebuilder manually and copy it into the building directory - next to the moa-setup.exe

working mirrors: ...

Re: MOA 2.4.1 setup

PostPosted: Mon Oct 04, 2010 5:02 pm
by tjblair51
Thanks very much for you work in developing MOA.

Your wizard to create the MOA core seems to only work with a specific build of VMware converter 3.0.3. I have downloaded VMware_converter_3.0.3_89816.exe (Starter Edition) and when the wizard asks if I want to install VMware Converter 3.0.3 it extracts the files but does not copy them to the converter folder.

With the previous MOA241-setup.exe I had found that if I manually copy the files and then rebuild the iso it does include the converter application and it runs but this is an extra step and is not obvious. It took me a long time and many unsuccessful builds to figure it out.

This does not work with the latest MOA241-setup-v3.exe. For some reason, even if I copy the files to the converter folder and rebuild the iso the _sfx_ folder is empty except for the SSL folder. I even tried copying the files from the pebuilder/BartPE from the previous version and that didn't work either.

Since the converter build you reference is no longer available from VMware would it be possible to update your installer to use the current converter?

On a (slightly) separate topic, do you have plans to integrate VMware converter 4 into MOA?

Re: MOA 2.4.1 setup

PostPosted: Mon Oct 04, 2010 5:59 pm
by messias
Kann ich bestätigen, wenn ich mit der CD Boote habe ich keinen Converter.

Was muss ich wohin kopieren um den Converter nutzen zu können?

Re: MOA 2.4.1 setup

PostPosted: Mon Oct 04, 2010 6:31 pm
by tjblair51
OK - I watched your video and discovered that you are using the same vmware converter build. I don't know why it isn't working for me. I am using a Windows Server 2003 Standard SP2 VM to build the images. I select the same options that you do in the video but the converter files don't get included in the iso. With the moa241-setup.exe I can get it to work if I manually copy the extracted converter files to the converter folder and then build the iso again. With the moa241-setup-v3.exe that I downloaded today, that doesn't work either.

I have no antivirus or firewall software in the VM. Any suggestions on what might be going wrong?

Again, thanks for your work in creating this and for making it available.

Re: MOA 2.4.1 setup

PostPosted: Tue Oct 05, 2010 1:21 am
by continuum

hmmm - I did not try the "include converter" option with the v3 setup.
Will do so now and look into it

... about Converter 4
that versions does not support the /boot switch - so it is not really useful.
Joakim has posted instructions how to work around that limitation - see the old forum post

Personally I never saw any reason to use Converter 4 with MOA.
I just use it occasionally for the "configure machine" option - and that can be used by installing it on the fly - or even smarter - by using a VM with converter 4.

The latest version 4.3 also has no -boot switch. Looks like VMware does not care for updates on that ...


Re: MOA 2.4.1 setup

PostPosted: Tue Oct 05, 2010 2:02 am
by continuum
Good news
the new v3 setup is expected to work with Converter

I just did a testbuild and it should look like this

For this build I started with a blank directory and add this files:


I used 2003 sp2 to build.

By the way - the most reliable system to build MOA is MOA.
So if you got one working version try to build with this one.

That rules out any firewall or online-virus-scans which may have prevented adding of converter in your case.

Re: MOA 2.4.1 setup

PostPosted: Wed Oct 06, 2010 4:59 am
by continuum
please check the MOA FAQ
just added some notes about converter ... t=37&id=40

Re: MOA 2.4.1 setup

PostPosted: Wed Oct 13, 2010 12:11 am
by tjblair51
I tried again with the same unsuccessful result. The only thing that I could tell that I had done differently was I used a different folder name to build MOA. Thinking that this might be the issue, I tried again using the folder name D:\moa241build and moa241-setup-v3.exe. When I built the MOA core it extracted the converter files to D:\moa241build\VMware_converter_3.0.3_89816 but did not copy the files to D:\moa241build\converter.

Following your instructions, I copied the extracted converter files to D:\moa241build\pebuilder\BartPE\_sfx_\converter, rebuilt the ISO and I have a working ISO with converter.

I built MOA on a Windows 7 Professional 64bit PC running VMware Workstation 7.1.2 build-301548. I did the actual build in a VM with Windows Server 2003 Standard SP2, no anti-virus or firewall installed. I don't know if any of this has to do with why I have to take the manual step to get converter in the ISO but it may not be worth your time to investigate this further.

Thanks for your help.

Re: MOA 2.4.1 setup

PostPosted: Fri Oct 15, 2010 7:43 am
by mike1140
I had also problems in building a functional MOA-iso. (got an iso which crashed on booting, another one with Bart-PE screen, than one without the converter)

What solved my problems was:
- naming the install-directory to "c:\moa24101"
- copy moa241-setup-v3.exe and VMware-converter-3.0.3-89816.exe in this directory.

This made me a full functional MOA. As shown in the video tutorial.

My working environment: VMware-Workstation with XP Prof SP3


Re: MOA 2.4.1 setup

PostPosted: Mon Dec 06, 2010 7:23 am
by nomad7
I apologize, but I am having a bit of problem understanding this.

here's my situation:
Server1 is an esxi3.5 server, It has 3 datastores, one has been accidentally formatted and I want to recover the VMs from it.

I downloaded moa241-setup-v3.exe and VMware-converter-3.0.3-89816.exe

I ran the moa241-setup-v3.exe, and it downloaded several zips in c:\moa24101
I then re-ran setup and chose ram-image-bandit

I then hooked up the resulting iso file into a VM and booted from it in a new VM within the same esxi server
After boot up, I expected to see what the video shows, except I only saw a few icons and nothing that looked like what the video showed.
I am attaching a screenshot of what my screen looks like.

I am also confused about which server to boot the iso from (moa24-rocker.iso). Can I create a new VM inside my esxi and boot from this iso or will it only work under workstation?

Any help for will be appreciated.

Re: MOA 2.4.1 setup

PostPosted: Mon Dec 06, 2010 11:39 am
by continuum
Hi Nomad

your screenshot looks perfect = looks like everything is fine with your iso.

Sorry - I do not see how that is all related to your ESX 3.5 server ... please explain


Re: MOA 2.4.1 setup

PostPosted: Mon Dec 06, 2010 2:19 pm
by nomad7
Thanks for taking the time to reply.

In the video explanation, it says, 'after a full boot of MOA-24-024, run esxi.exe. This will extract a small esxi-vm and opens it in workstation 6.5"
I see no esxi.exe when I boot from the ISO
How it is related to my esxi server is that I am booting the moa from within esxi as a new machine.
The datastore I want to recover files from resides on this esxi.

I am attaching some additional screenshots that may help understand my scenario.
Perhaps, I am not understanding the concept.

ESX Screenshot
another screenshot

Thank you.

Re: MOA 2.4.1 setup

PostPosted: Mon Dec 06, 2010 3:38 pm
by continuum
you then watched a video where I explained to use a ESXi VM to recover something from VMFS.

Sorry - I can not re-distribute that esxi.exe I mentioned in that video.

best would be if you explain exactly what you want to do


Re: MOA 2.4.1 setup

PostPosted: Mon Dec 06, 2010 4:04 pm
by nomad7
OK, Here's what happened:
After a power outage, one of my datastore was missing so I accidentally, 'scanned' for it again and re-added it, which ended up reformatting it.

In fact, I later learned that the solution was simple:
All I had to do was in Infrastructure Client, navigate to Configuration -> Advanced Settings -> LVM, and set "LVM.DisallowSnapshotLun" to "0". Save the settings and refresh the Storage

Now, I had several VMs on this 500GB datastore and I am trying to recover as many VMs as I can from that datastore.

This datastore shows up in esxi as indicated in the previous screenshot, however, it shows as having no data (because it was formatted). I hooked up the HD to a data recover program and I'm able to see many files, but no vmdk files. All I see is are the actual contents of the VMs that were on the datastore, example, I had several Windows VM, and I'm seeing the contents of those machines.

I can set up remote SSH access to the vm box, if needed.
Looks like your esxi.exe would help do that.

This is an ESXi 3.5 Build 207095
It has 2 other data stores that are fine.

Re: MOA 2.4.1 setup

PostPosted: Mon Dec 06, 2010 4:16 pm
by continuum
After a power outage, one of my datastore was missing so I accidentally, 'scanned' for it again and re-added it, which ended up reformatting it.

Oh dear - then booting with a second ESXi will not help at all - too late for that.

If you are very very lucky - you may still see something from your old VMs if you use a recent Ubuntu-LiveCD and install the "vmfs-tools" after boot.
But I seriously doubt it.

This is now a case for a recovery company like Ontrack - or if you do it yourself I recommend to use Ontrack easy recovery.
You will not find any vmdks - all you can extract is small original files that were stored in a single fragment inside the vmdks.

I have done the same in similar cases - sometimes I could recover small but important files after days of scanning ...

:| - sorry for the bad news