Page 1 of 1

Help Please!!

PostPosted: Sat Dec 25, 2010 7:35 am
by liftgat
I have a working VM.

However, I probably have a bad sector in one of my vmdk files - I get I/O errors if I try to do a backup, if I try to copy the bad vmdk file, if I try to create a new migration to a new copy, etc. Worse, I learned about this when my backup failed (on my 1 backup drive, which means it also ruined my only good backup).

So I stayed up 2 days extracting critical data files, but the thought of a new install from scratch is excruciating - I have a 750G drive!

Then I found SICKBAY, and followed all the instructions to the letter.

Please help me retrieve my installation so I can put it on a clean hard drive?

Thank you!
Very tired girl

Re: Help Please!!

PostPosted: Mon Dec 27, 2010 1:25 pm
by continuum
Hi
your VM has snapshots - so first thing to try is to remove the snapshots.
Once the snapshots are removed i would try
vmware-vdiskmanager -R against those vmdks

Re: Help Please!!

PostPosted: Tue Dec 28, 2010 7:19 am
by liftgat
Hi thank you for responding. Yes - As I wrote in the notes-

I already tried removing them and the consolidator failed half way through.

Now what?

Re: Help Please!!

PostPosted: Tue Dec 28, 2010 1:17 pm
by continuum
if the VM still works - looks like that - you could use Converter to clone it.

Did you try vmware-vdiskmanager to remove the snapshots ?

Re: Help Please!!

PostPosted: Tue Jan 04, 2011 10:47 pm
by liftgat
Yes, as I said in my file - I already tried using the Converter, which failed.

I did not try vmware-vdiskmanager, because the page I found y'all on said not to.

Is that my only option? If vdiskmanager fails, doesn't it ruin what I *do* have?

Re: Help Please!!

PostPosted: Fri Jan 07, 2011 4:05 pm
by continuum
vmware-vdiskmanager is harmless - you would use it to consolidate all snapshots into a new vmdk
so even if vdiskmanager fails the original disks are not changed