Page 1 of 1

Request

PostPosted: Wed Dec 01, 2010 5:46 pm
by vvurat
I prefer to use dart tools as loader always. When winpe starts it starts "netstart.exe,-prompt" after that it asks "Do you want to start network background?" and runs "wpeutil -initializenetwork" after it asks "Do you want to automount drives background?" and runs something i don't know.

When i only use "netstart" it runs all at background but WAITS wpeutil works to finish before load shell. When i use with "-prompt" it loads shell directly and continue to work wpeutil background. I DO NOT want to wait to wpeutil finish it work to run shell also I DO NOT want to see prompts at start (I want netstart behave as user clicked on "yes" twice) It needs hexediting and disassamble (especially i know joakim good at this)

Anybody can help on this subject?

Re: Request

PostPosted: Wed Dec 01, 2010 7:36 pm
by JFX
AutoIt can automate these two clicks netstartx.7z

Just put it in the same dir as netstart.exe and run it instead

Re: Request

PostPosted: Wed Dec 01, 2010 11:43 pm
by vvurat
thanks. i downloaded a few times but everytime winrar says corruption. file is broken or need to install 7z?

And what about custom MOA winpe builder project? No news?

Re: Request

PostPosted: Thu Dec 02, 2010 12:14 am
by JFX
ohh, sorry was LZMA2 compressed. Forgot that I have set it as default in 7-zip

For MOA seems you will have to wait http://forum.sanbarrow.com/viewtopic.php?f=80&p=131#p131

But you know, the longer you wait, the better it gets.

Re: Request

PostPosted: Thu Dec 02, 2010 10:30 am
by vvurat
Can you put also ("network->No", "Mount->Yes") compiled one inside that zip to another folder. Really i didn't interested about autoit. And do not know how to compile your source. It looks simple source but i do not want to make a wrong thing.

Your winlogon autoit patch also works for x64 bit too. I tested. You don't comment will it work for x64 bit or not.